Issues with Android Auto

Discussion in 'Clarity' started by Crota, Aug 30, 2018.

  1. peekay

    peekay New Member

    These work fantastic. Much better than my oem Samsung cables.

    Micro USB Cable Android Charger -... https://www.amazon.com/dp/B01GFB1SLC?ref=ppx_pop_mob_ap_share
     
  2. ozy

    ozy Active Member

    Thanks. Just placed the order.
     
  3. Olimpia

    Olimpia Member

    80% of the times I plug my phone I keep getting an error saying "unable to connect smartphone bluetooth" or something to that extent. The solution is simple, I just have to unplug the phone and try again but really annoying to do this so often until "it works". I doubt the USB cable I'm using is the issue since it's the original cable that came with my Google Pixel XL.
    I believe the original Google Pixel phone is known for having unreliable bluetooth connection so I'm wondering if that's the issue here.
     
  4. Bryan Keil

    Bryan Keil New Member

    Although I have not read all the posts, I have information that may be unique. I have 2 cars with Android Auto that both my wife and I use. In the Ford Focus Electric both of our phones (Galaxy S7 edge and S9 edge) work flawlessly. In the Honda Clarity, both phones disconnect constantly. We use the same cables in both cars. Perhaps it is just a janky USB port in the Clarity. I also drive a Chevy Volt at work with Android Auto with no issues. I have been in other cars with Android Auto and have not had issues. It is only in the Clarity that it does not work properly. Of course, looking around the Internet, it seems that many, if not all makes of cars seem to have this problem. Perhaps it is just a high quality cable that overcomes the crappy USB connectors that are in some cars.
     
  5. MPower

    MPower Well-Known Member

    Somewhere in the owner's manual it says to use the OEM cable. I tried several cables with my S7 edge none of which worked except for the OEM.

    When I got my new phone S10+, I just used the OEM cable and it works fine.

    I have had no trouble connecting with AA except when I used a non Samsung USB cable.
     
  6. jack.

    jack. New Member

    I had tons of disconnect problems with every cable I tried with my Pixel 2 XL, including the OEM one. I bought an Anker Powerline II+ on the recommendation of the AA subreddit and it has been a huge improvement. https://www.amazon.com/gp/product/B07G114FZ7/
     
  7. Ragman

    Ragman New Member

  8. JCA

    JCA Active Member

    My sense is that there's an issue with either the phone or car's implementation where a brief interruption/corruption causes the car to drop the Android Auto session, instead of retrying. That makes it much more sensitivity to cable quality than it should be. I too was getting a couple drops a day with some cables, and fewer (maybe once every couple weeks) after I got this cable: https://www.amazon.com/gp/product/B01A6F3WHG. I have no idea how much is related to the cable's internals, and how much to the age/looseness of the connectors (which may be related to cable quality). It's annoying, because cables should be standard and the protocols should tolerate some errors gracefully, without stupid tech support things like "only the cable that came with your phone".

    Another thing to check is whether your phone's USB port needs cleaning. I was having issues with even charging not always working and cables falling out, and it varied by cable so I thought it was either the cables or a permanent failing of the phone's port. Turned out there was a bunch of lint packed into the bottom of the USB-C port that kept the connectors from fully seating and latching. I had to go in with the pointy end of a safety pin (turn the phone fully off first!), and poke and dig carefully but firmly until I got out way more lint than I expected. After that all of the cables latched properly, and I had fewer Android Auto disconnects with any cable (but still not almost zero until I got the new one above).
     
    Ragman likes this.
  9. Mowcowbell

    Mowcowbell Active Member

    I picked up a couple of these USB C cables and another advantage is they provide 'rapid charging' when plugged into a USB power source when my other cables only provide standard speed charging.
     
  10. Ragman

    Ragman New Member

    After I receive the new cables I'll look into "resetting the console" as mentionned by RYD994 in an earlier post.
     
  11. megreyhair

    megreyhair Active Member

    I have problem with AA with my moto z2 phone from time to time. Rebooting phone or head unit usually resolve the issue. On my phone, it will always default to usb charging when I connect it up and I would have to go and change the usb mode to ptp. Also AA uses bluetooth as well. So make sure that is working.
     
  12. Ragman

    Ragman New Member

    Yesterday, received the cables suggested by member peekay: https://www.amazon.com/dp/B01GFB1SLC?ref=ppx_pop_mob_ap_share. Plugged in the cable and went for a drive with no issues. It appears that the short (6") extension I was using with the supplied OEM cable might've been the culprit of the problems. I'd removed it using only the OEM cable and had no issues. But I used the new longer cable and it worked fine, and I put away the OEM shorter cable.
     

Share This Page